mercredi 19 octobre 2011

autoshutown 2 the return

Finally i got the reset of autoshutdown working .. (need to verify but don't know how to do a midi note every 20 sec without doing it manually).

When pressing the "erase button" it connect the pin 6 to the pin 33 in the microctronller (via the membrane keypad), the pulse shown in the previous post will output from pin 33 and goes in the pin 6.

After few tests the conclusion is :  needed to recrate this pulse and it need to be well synced with the signal from pin 6. Using port maipulation i get env, 500 ns difference between the received pulse and the created one.
Normally this pulse should simulate a "erase" keypress and erase the screen if you press a letter button before.i execute the function (generate the pulse after every midi note) and strangely it does not erase the screen each time .. but seems to reset the autoshutdown counter correctly. To be sure it will erase the screen i should do a few of theses pulses, be they appear each 7,x ms , so if i want to put 4 pulse it will take approx 30 ms, after each midi note, which is far too much i think if you want to trigger the note quickly (not sure the S&S will accept not ever 20 ms need to be tested). i prefer to keep responsiveness of the S&S.

I also tried something totally different, remove the negative voltage from the interface and replace it with the GND, it should work in theory because the bus should have pulldown resistor.
Result  : it works , yeah .. but with some interference on the VFD display.

With the negative voltage
 correct screen with the underscore (the ctl8 pulse is due to this underscore)


Without negative voltage  you get strange display but works.

I'm tired of all this cable and stuff
 that's why i'm designing a sort of shield (smaller one)for arduino, once done, will sent it to a PCB prototyping service.
This shield will be usable to the arduino to S&S interface, will power the arduino with S&S batteries, it could also be used as a midi shield.

3 commentaires:

  1. I realise you're probably the best person to ask this :
    I tried to program my arduino to send short trigger pulse to an analog drum machine, when I press midi notes. I scavenged a midi interface from an atari 1040stf and arduino get midi messages. Now I'm stuck to the program with on an off states when I press my midi controler. It only reconises note off, and cycles between on and off output... It's quite simple... Can you help ?

  2. Hi,
    Difficult to say what's going wrong without the full or part of the code.
    if you send me the code (and a little schematics if you have it) i will be happy to help you ..
    you can send me a mail at noizeinabox at

    Typical prob with midi on or off is that some (a lot) of midi devices do send note off with a "note ON velocity 0 "